Jabiim Consortium
  2060 active members
  194 are online

Year

19

Day

329

Time

22:44:15

Guest
Login
snewsgnewsmessagegeneralfactioninventorycombatroom
Year 12 Day 122 14:51
Ven Ann

I have problems loading npcs on ships.

I know you can load only 100 at a time, but couldn't the software load the first 100 by itself and leave the rest there instead of giving an error message?

Because clicking 100 times each time you want to load something when you have thousands of npcs to move is a real pain and time consuming for nothing. Could a small code be included that tells the software to choose the first 100 selected entities and then execute the command we are giving them?

OR, make party page list only 100 npcs at a time so that when you select all of them, you select only 100.


While I am at it, I got this error message when I tried to load over 100 npcs (for our techs) :

An error occured: Lock wait timeout exceeded; try restarting transaction => INSERT INTO entityLocation SET `entityID` = 1279667, `entityType` = 10, `containerID` = 10933375, `containerType` = 6, `topContainerID` = 154592, `topContainerType` = 2, `galX` = 461, `galY` = -37, `sysX` = 12, `sysY` = 6, `surfX` = 4, `surfY` = 2, `groundX` = 10, `groundY` = 21, `lastGroundX` = 10, `lastGroundY` = 21, `travelClass` = 0, `sectorID` = 42, `systemID` = 363, `planetID` = 1837, `cityID` = 235, `travelID` = null ON DUPLICATE KEY UPDATE `entityID` = 1279667, `entityType` = 10, `containerID` = 10933375, `containerType` = 6, `topContainerID` = 154592, `topContainerType` = 2, `galX` = 461, `galY` = -37, `sysX` = 12, `sysY` = 6, `surfX` = 4, `surfY` = 2, `groundX` = 10, `groundY` = 21, `lastGroundX` = 10, `lastGroundY` = 21, `travelClass` = 0, `sectorID` = 42, `systemID` = 363, `planetID` = 1837, `cityID` = 235, `travelID` = null

When I try to board less than 100 I get 404 Not Found
nginx/0.8.54.


Edited By: Ven Ann on Year 12 Day 122 15:10
____________

To all problem there is a solution... for a price of course.
- Kiva Ven'Ann
silverLargeSymbol.gif Clan Ven
Year 12 Day 122 16:01
That's a server overload error, I believe. Give it a few minutes and try it again. Probably too many people trying similar things at once.


____________

"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 12 Day 122 16:02
perhaps you shouldn't have 1,000s of NPCs in the one room


Year 12 Day 123 15:15
Ven Ann

They're not in the same room, they in a city.

Today I get 404 Not Found nginx/0.8.54 when I try to load many npcs at a time. Overload of server? Maybe get better sever or defrag or some other maintenance that would speed it up (last two much cheaper ;) )?

I don't want to waste my time clicking each individual npc to load them somewhere, I want to select them all and then just say to them "get in there if you can, as for those who can't stay there."

I hope this won't last several days, I have to do this soon.


Edited By: Ven Ann on Year 12 Day 123 15:17
____________

To all problem there is a solution... for a price of course.
- Kiva Ven'Ann
silverLargeSymbol.gif Clan Ven
Year 12 Day 123 19:14
ok then. perhaps you shouldn't have 1,000s of NPCs in the one city


Year 12 Day 123 20:44
Maybe it's not her fault, Clarr?

And if SWC can't support 1,000s of NPCs in one city (or room), perhaps it shouldn't be possible to put 1,000s of NPCs in one city, or room.


____________

"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 12 Day 125 12:18
Ven Ann

Good point.

Also, if we can't have thousands of npcs in a city, how can you defend it? Makes little sense to defend a city with only one hundred men.

I am still getting the same message today (sunday), so I guess they did not fix it yet.


____________

To all problem there is a solution... for a price of course.
- Kiva Ven'Ann
silverLargeSymbol.gif Clan Ven
Year 12 Day 134 19:04
Lorenzas Atticus

I am experiencing a very nasty travel bug infecting 36 recently hired NPC's that I reported to the Bug Base about 3.5 weeks ago. I heard from Asim that they are looking into it. Maybe your issue is related? Hopefully they will resolve it soon.