2113 active members
  222 are online

Year

19

Day

302

Time

03:43:06

Guest
Login
snewsgnewsmessagegeneralfactioninventorycombatroom
Year 13 Day 307 4:28
First time posting so I'm sorry if i'm in the wrong forum:

Since this weekend's upgrade I've been noticing trouble talking with my NPC. In particular, 1- wildcards are not always being recognized. 2-I have yet to get a 2nd set of responses as the conversation develops; the script just stops.

Anyone else having this problem?


Edited By: Cado Ava on Year 13 Day 307 4:29
Year 13 Day 307 6:03
Per the second, it is possible that the Responses section is incorectly formated, so it will just think there are no responses required by the player. Check the spelling, that there is a colon immediately after, and there is no space in front of the lines.

Per the wildcards again you may be formatting them incorectly, depending on which you are using. Some are only useful when using them in the !wild.card! format as they give no response when using the %wild.card% - yes it does make a difference which you use.

If you could post your script (or just DM me) we can more accurately see what the issues are.


____________

Ellias_sig6.png
Year 13 Day 307 7:33
Oops, sorry for the confusion using the word 'scripts'

I was reffering to a resident NPC I hired, not a CP NPC.


Year 13 Day 307 17:38
Could you post the conversation you can access so I can compare it with the script itself and see whats up.


____________

Ellias_sig6.png
Year 13 Day 309 15:08
CONVERSATION with an NPC resident I hired:

[Krenis Axfow]
Not much. A little bit of this, a little of that. Do the odd jobs that usually turn up everywhere.

[You]
Hi, I'm %player.name%. What do you get up to?

[Krenis Axfow]
Hi there, I'm Krenis Axfow. Welcome to my little home.
I've not settled down yet. Still got some adventure left in me I think.

Issues:
1-Before the upgrade my name 'Cado Ava' would appear where the wildcard is
2-The conversation has just sopped here. I know my resident has more to say becuase I've read it before.

Any thoughts would be great Ellias?


Year 13 Day 309 18:13
Well, I can see why your name wasn't working - the wildcard changed from player to character so I'll fix that now. FOr it not progressing, not sure. My little tool to test the scripts carried on just fine. See if it continues normally now, and if not, try looking at a different resident see if the issue is the same there too.


____________

Ellias_sig6.png
Year 13 Day 311 8:24
I just bought a new resident and the conversation still did not progress. wierd...


Year 13 Day 311 15:13
Ruben Wan

I confirm the same problem, with a Custom NPC.
I opened a bug report here: http://bugs.swcombine.com/view.php?id=2433


____________

Ruben Wan
KuTBv1W.png

Year 13 Day 315 7:36
Thanks Ruben! I'm glad I'm not losing my mind...