2018 active members
  175 are online

Year

20

Day

237

Time

02:33:56

Guest
Login
snewsgnewsmessagegeneralfactioninventorycombatroom
Message CentreRPG CentreQuestion Centre
Archives » internet explorer/Combine question.
Hadrien Bahz

Might be a silly question but I'm new, do I need to upgrade from Internet explorer 6.0 to 7.0? Game seems to be running, but I noticed this on my edit account area. Thank you in advance for your time.


Hadrien Bahz

I have also noticed that I cannot access my travel section, perhaps this is related? Sorry to post back to back, but I figured this update was relevant to my primary question. Thanks.


Dayyn Gorvai

I don't see why you shouldn't upgrade your browser. Sometimes minor problems will be fixed.


Hadrien Bahz

I'll try it, I'm just hesitant to download.


If you encounter problems, generally the first thing we do is ask you to ensure your browser is up to date. Since the developers all use the most current version (usually Firefox, rather than Internet Explorer), it happens every so often that features will not function properly on outdated versions. It is your choice, and if you aren't having any problems it likely doesn't matter, but bear in mind that browsers are updated for a reason, usually to fix bugs and security holes, and that upgrading is generally in your best interests in the first place.


____________

swcforumsig