2059 active members
  179 are online







Year 10 Day 266 11:29
I typed in my password correctly but it doesn't let me login!

Year 10 Day 266 11:38
Have you read the thread named "Problem: I can't log into SWC"?


Year 10 Day 268 11:07
I've typed it in lots of times and wont let me log in

Year 10 Day 268 11:34
That doesn't really answer my question ...


Year 10 Day 291 19:04
I have the same problem too.. I tried different Net browsers but they all show "Your session expired. Please log in again." after I typed in the correct handle and password.. This also happened when I tried to join about a year back..

Year 10 Day 291 19:58
First, you should of started a new thread. Second, nothing can be done without your handle - the ASims are not telepathic. Third, seems like you need to be added to the session exemption list.


Year 10 Day 300 11:05
I am having troublelogging in for the first time after I put in the handle and my password and hit log in the fields go blank like I never typed anything in there, can someone help me?

Year 10 Day 302 8:22
Tsavong Tal's password does not work! Help! I can't even start another account!

Year 10 Day 302 9:50
First off you should really start your own thread. Anyway.
Try copy pasting it directly in (just make sure there are no extra spaces)
If that doesnt work, have you tried the password recovery?

Year 11 Day 62 18:44
i'm having the same problem!! I can't log in. It says that my password is wrong but it's not!

Year 11 Day 63 3:52
Please make a new thread for your problem.