Moretti Industries
  2123 active members
  261 are online







Message CentreRPG CentreQuestion Centre
Archives » Is this a bug? Or am I missing something
Umbeck Traxer

I am trying to mine, and I thought I had set up everything correctly however it is not allowing me to add workers to mine.

So what am I missing now?

To extract the materials you must satisfy these conditions:
•The owner of the Mine must be a faction.
---It is owned by a mining faction, done.---

•The Mine must be powered.
---yep I checked that. Done----

•If the owner is a Mining faction then there must be a Manager and an Operator (any faction or character).
---that's me, already took care of that---

•The NPCs used in Mining must be owned by the owner or operator of the mine.
---owned by the operator, me.---

So how come I can't add NPCs? Do they need to be in my party to assign them? Tried that. Out of my party? tried that too. I'm in the command room... I even dumped some off in the hangar in case that was where they had to go or something, I was out of ideas.

Assign NPC to Work
No Mining/Farming NPC Available

Mining Information:
Employees: 0

You have no employees assigned to mining.

I'm not sure what else I need to do.... is it a bug that doesn't allow me to add them or is it something else that I am overlooking?

Xavze Zavan

the npcs owned by operator only works if you are in the mining faction as your personall NPC become members of the faction you are in--note-if you leave..they do also and mining will not repeat

Simplest fix is to make over the NPCs to the faction that owns the mine


How would you like to pay income tax EVERY month?
Tal Dorn

Xavze Zavan, would it work if you assigned the mining faction as manager of the NPCs?

I think the only way it will work is if the NPCs are owned by the mining faction. Somone yesturday tried to start up a mine, owned by a mining faction, and he was in the faction but still couldn't start it up until he made them over.

Either the rules needs to be changed, or someone needs to make a bug report and get one of hte coders to have a look at it.

Oh, and they have to be not in your party.


Umbeck Traxer

Sending to the mning factin worked. But yeah the rules seem inaccurate to me

Kuro Neko

I had a similar problem

Mines owned by mining faction (XXX Miners)
Mines operated and managed by Kuro Neko (Alissma religous faction)
NPCs owned/managed/supervised by Kuro Neko

I regularly used to be able to start the mines myself while still in Alissma, but usually they would not repeat. Then about 3 weeks ago I got the "No Mining/Farming NPC Available".

I didn't change anything, it just stopped working in the way it used to work.

I sent the NPCs to XXX Miners and was able to start the mines... and they repeat too.


There is no god but Ara... All will walk his path...
The Faithful of Ara <--- (Warning: music link)
Yeah - so best to make a bug, and maybe bug a coder to take a look. Might be less of a priority since it can be made to work my making over the NPCs, but that just means it doesn;t work as advertised.


Kainen Morguli

NPC's also don't have to be in your party. They do HAVE to be at the entrance though.

...ive gotten them to work at a cockpit by just releasing once i got there. has that changed?

Kainen, the NPCs cannot be in your party. If they are, they won't be available to work, even if everything else is correct.