2051 active members
  249 are online







Year 7 Day 158 11:23
Matt Yarrick

Ahoy, I've just tried to join this game. I've chosen where to start, but when i click on travel, it just comes up with a blank screen. What's the problem with this? Please help me

Year 7 Day 158 12:31
Please read the sticky posts at the top of the forum, more than likely your browser is not upto date. I suggest you download and install firefox.

We are 100% compatiable to firefox and maybe 75% to IE, not sure about AOL or netscape or other browser.



SWC Fanpage --\\\\-- SWC Twitter
Year 7 Day 159 2:28
Aiden Cook

No Star Wars combine is O.K. with netspace I'm using it now.

Year 7 Day 159 9:19
Matt Yarrick

My browser is BT yahoo! if that helps?

Year 7 Day 159 9:24
Matt Yarrick

Ive just tried downloading foxfire, but it says there's an error

Year 7 Day 159 13:42
Bryce Armadala

Was the mispelling "firefox" the error?

Year 7 Day 159 23:48
Matt Yarrick

Soz, thats my mistake. Firefox i meant

Year 7 Day 159 23:50
Matt Yarrick

But still, Im gettin this blank screen when i click on travel

Year 7 Day 160 22:58
Aiden Cook

It could be a bug? report it http://www.swcombine.com/bugs-iframe.php you have to register first. It might not be a bug though

Year 7 Day 161 23:50
Matt Yarrick

OK cheers

Year 7 Day 165 13:18
Matt Yarrick

Nope still not workin

Year 7 Day 168 0:03
Matt Yarrick

can anybody help??!

Year 7 Day 169 13:06
Matt Yarrick

rar its not goin to work!!!

Year 7 Day 169 15:35
There have been other threads of the same issue. Have you tried looking those up to see if it was resolved?

Have you reported it to the bug base? If not, why not? If yes, has it been assigned?


"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 7 Day 169 23:34
Matt Yarrick

I have reported it in the bug thingy, nobody's responded to it yet. And yes, i hav tried to find other threads about it, but they dont really help

Year 7 Day 173 11:00
Matt Yarrick

On the bug report forum, the dude says he has fixed it, but he hasnt! its still a blank screen

Year 7 Day 173 12:29
Then put a note on it. Or try Darkness messaging him to tell him it still doesn't work, if he closed it.


"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 7 Day 176 12:37
Matt Yarrick


Year 7 Day 176 13:52
Just hang in there man. Things make take a while but these guys are really good about fixing problems.

You said you had an error downloading Firefox? Maybe theres a problem with your internet connection. I know that when I play on a slow connection (like at work) it takes a minute for the screen to 'fill in' and I only have a gray and red screen for a few seconds. It could just be a problem with your computer.

I usually start with the simple stuff, Run anti-adware, spyware, virus, clean registry, delete cookies, defrag, etc etc. Reboot the computer, make sure you don't have anything stupid running in your process menue. See if that helps. Do you have another place you can log on from? Home, work, school, a relative/friend?

Edited By: Daktal Hearst on Year 7 Day 176 14:01

Year 7 Day 180 14:09
Matt Yarrick

I could do, cheers for the help