The Angry Rancor Distribution Company
  2033 active members
  178 are online







Message CenterRPG CenterQuestion Center
Archives » Application Rejection question
Year 8 Day 176 5:52

I just tried to apply but got the following rejection:
This IP has tried to apply with several handles at once. All requests are declined as we can not know which one is correct. Please apply again with only one request and be patient.

I'm curious as to what to try again. I just found the game so I've only applied once. The one thing is that we are on a satellite connection and using a router. Nobody else in the house plays the game so it can't be that. Could there be a problem with satellite connections where the game sees us as the same IP for some reason?

It's the only unique thing I can think of. If you have any ideas to get me up and running, I would definitely appreciate it.

Alternatively, I can activate the account from another machine (say at work) but I fear that will cause me to be unable to login.

Thank you!

Year 8 Day 176 7:03

same here its f@@@@@@@ retarted

Year 8 Day 176 9:57
Best thing really would be to try signing up again. If you are afraid that your account will be declined again, feel free to post the handle you signed up with here so the people who check accounts can find the problem more easily.