Blackscale Clan
  1989 active members
  234 are online







Year 10 Day 334 8:56

I have waited for over 36 hours and I have still not gotten a password. I did check he lost password tool and it said account not activate yet. Should I jut keep waiting?

Year 10 Day 334 8:58

The i forgot the t on the the that it why it says he password tool.

Year 10 Day 334 9:32
By the looks of things only one account has joined in the past 24 hours so I would imagine a few more are waiting to be approved, yours being one of them.

Year 10 Day 334 10:59


You lost patience first :)

I was planning to write a similar text tomorrow, as I\'ve waited only for 30 hours :)

Oh well, patience.

Year 10 Day 334 16:32

It has been over 48 hours now.

Year 10 Day 334 17:17
It seems that only a handful of accounts have been accepted int he past 24 hours. I'm sure you'll be accepted shortly, just give it a little time.

Year 10 Day 334 17:21
I think many of those who regularly review applications have been busy lately with the server instability we've been suffering. I've found time to accept accounts some days (I usually just skim down the list and deny the obvious violations - it's quicker) but not so much so far this week.

So the good news is that if you haven't been rejected yet, your handle is probably okay. The bad news is that it might be a while longer before someone (perhaps myself) gets the time to properly go through all the apps and accept them.

Year 10 Day 334 22:23

Oh well, my application was rejected because \"This IP has tried to apply with several handles at once.\"

This must be one amazing game, as getting in is this hard.

I don\'t know what went wrong there. Would have been nice to try this game, but to he honest, I\'ve never played a game, where getting in the game, has been this hard.

Year 10 Day 334 22:31
it's really not that hard. There are a couple of things that could be causing your problem.

- You are logging on from a public place.

-You tried creating more than one character

-some other issue I can't think of right now cause it's late.

Most people don't get the problem you are having. Emphasis on MOST.
I would advise asking an admin.

EDIT: NVM seems you already have a topic in the Questions for Admin area

Edited By: Tuural Snist on Year 10 Day 334 22:33
Year 10 Day 335 4:10

Just to add (my posts in this chain are: 4th and 8th)

No, I didn\'t try to join from a public place, my home is not public.

No, I didn\'t try to create several characters.

Application went fine, as far as I can see, but the result is that I was rejected. The reasons to that is a mystery, but good luck and fun for those that were approved!

This is just my typical luck really.

Year 10 Day 335 4:19
Quite possibly you share your ISP address with a few others who use the same internet provider. I suggest starting a new thread detailing the issue and providing your email address, then reregister for an account.

Edited By: Breske Ciali on Year 10 Day 335 4:20
Year 10 Day 335 6:03

It has been over 60 hours now. The things I wrote were 1 and 5.

Year 10 Day 335 13:35
Posting hourly time updates absolutely will not assist your application in any way.

Year 10 Day 336 7:55
Obi Right
Obi Right
I have it now.

Year 11 Day 75 18:51

ive just made an account today is febuary the 10th 2010 when will my thing come i can only create a handle and not a race or anything please help ist sooooooooooooooooooooooo cool