Faerytail Trading Company
  2009 active members
  119 are online

Year

20

Day

355

Time

03:12:05

Guest
Login
snewsgnewsmessagegeneralfactioninventorycombatroom
Year 10 Day 348 11:59
Tiffany Alaxzander
Tiffany Alaxzander
I'm at the right location, in the same place I brought the items from. Have tried to equip them both through Inventory menu and using Items button in the same room (this just brings a black page). so why can't I equip them?


Year 10 Day 348 12:03
You should be able to equip them from the "Items" button on the position page. If they don't show up there, then they are in a different room. Make sure the roomID of the room you are in is the same as the roomID that's visible in your item inventory.


Year 10 Day 348 12:29
Tiffany Alaxzander
Tiffany Alaxzander
I've done that for all the rooms but my items are still not there. but there are some items but not the ones I brought.


Year 10 Day 349 18:52
Nick Dusk
Nick Dusk
If you do it right, you should be able to put it on your belt, right, or left hand and go from there.


Year 10 Day 350 6:54
It's possible that your items were moved into containers. Can you check your inventory if they are stored in one of the containers that are in your current room?
If so, you can "open" the containers and take the item(s) out.