1987 active members
  234 are online







Message CenterRPG CenterQuestion Center
Archives » Inability to Achieve Achievements
I am having some trouble with some of the Achievements. For some reason, I cannot achieve the construction one or the using item one. Im not sure if there is something specific you have to do. I have Build entire cities for both my faction and myself, and installed multiple doors. Im curios if anyone else is having any trouble with achievements (I know brawling cannot be done due to npcs lacking speech trees) or could give me any tips for getting them.



I have been trying to get the use item one, I am currently attempting to make a key card and seeing if that works. I know that bacta patches are not the answer. I have yet to start construction, so I cannot answer for that one. What about the hail achievement?

Sim Karr
Sim Karr
Hail worked for me when I tried it with a droid. But it wouldn't work when I tried it with a ship.

Vincent Strife Antaria
Vincent Strife Antaria
Crafting a keycard doesn't get you the 'Use Item' one, I tried though it probably should.

By the looks of it the Using Item and Cosntruction ones don't work. It may that they were added to the list before the code was put in to get them. PUt it on the Bug Base so that one of hte coders dealing with it can fix it if its laready been coded.

Thanks for that tip Sim (tried it with a ship with no result as well :P)

Is NPC Transport getting into a transport opperated by an NPC, or a transport containing NPCs? (and if the first, where/how do you do that?)

And you have to join another players' party to get the achievement? Not form your own?

Sim Karr
Sim Karr
I believe you must go to the starport and purchase/use NPC transport to another starport.

I've created my own party before, no achievement with that, I think you need to join someone else's party. Each player has the option in account settings (?) that allow others to join them. I'm pretty sure that's how to achieve this.

Much thanks (again)