Ubrikkian Industries
  2055 active members
  166 are online







Year 11 Day 247 18:00
Matheteis Eimi
Matheteis Eimi
I am finishing up the last few 1x1 facilities in a city of mine. However, when I go to build the facility, it says I have no free space to build. But, the City Designer allows it and I am fulfilling all the requirements to build (standing still, sufficient builders, standing to left or above, two sides open, sufficient credits/RM's). I can't seem to figure it out. What am I doing wrong?

Year 11 Day 247 18:02
If you're using touching sides (North and East, for example) for the roads, is the corner blocked?


"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 11 Day 247 18:19
Matheteis Eimi
Matheteis Eimi
That could be it. One facility has an open space on W and E (facilities on N and S), and the other one has free sides on W, E, and S (facilities to SE, and SW).

If that's the problem, the City Designer didn't catch it.

Year 11 Day 247 18:34
It always wants to put the corner in when you put roads on adjacent sides, but you don't need the corner to pass the 2-sides check. So ideally you should build it first, then remove the road. If you try to build it when the corner is filled, it won't let you.

But it sounds like that's not necessarily the case, especially since you have one with W and E open.

Stupid question - there isn't road where you're trying to build, is there (from a corner of another facility, for example)?


"May the Grace of Ara go with you, and His Vengeance be wrought upon your enemies."

Only fools and children dream of heroes.
Year 11 Day 247 19:08
Matheteis Eimi
Matheteis Eimi
There are roads around it. Before attempting to build I was going to destroy the roads on the sides where I planned to build, but the coords to destroy roads I needed in the dropdown list were not there. Maybe I can't destroy the roads because of the 2-side requirement of the existing facilities??

But then again, I just started construction at a location where roads were present around the facility.

Year 11 Day 247 19:23
Matheteis Eimi
Matheteis Eimi
Yeah, tried to break up the roads in that area. Cannot. I've got to be doing something wrong...

No big--just a couple small facilities. Just surprised the City Designer allowed it, but in reality you can't.

Edited By: Matheteis Eimi on Year 11 Day 247 19:25
Year 11 Day 247 19:39
Existing roads will have no effect on building - I've built numerous times where the roads are already around the construction site. I think I have also built where I've needed adjacent side but the corner was already filled with a facility and it still worked.

Could you do a screen shot of the city from the position page (not from the city designer) - could be that there is an NPC there building one of the other facilities, or walking through. You are selecting the right location yes? Sounds like there is not much room anyway, but could be a possibility.


Year 11 Day 247 23:01
Teyacapan Quetzalxochitl
Teyacapan Quetzalxochitl
If it says there is no free space to build then that means you're not standing in the right position in relation to the square you're trying to build in.

Year 11 Day 248 9:55
screen shot the construction site.

if you can't delete roads then that means at least one of your facilities in the city is breaking the "two roads" rule, meaning you have to fix that first before you can add more.