Czerka Mining and Industrial
  2088 active members
  227 are online







Message CenterRPG CenterQuestion Center
Archives » Can't log in to create character
Problem: The main page refreshes when I try to log into SWC.

Solution: There are a number of possible solutions for this:

1. Try the Lost Password feature (again). Also remember that the password is case sensitive.
2. Clear your temporary files and cookies. In IE this is under
Tools->Internet Options.
3. Ensure that your browser is set to accept cookies.
4. If all else fails, you will almost definitely be able to log in with an alternate browser, such as Firefox (

I have done all of the steps listed, but have been unable to even log in once to be able to create my character. I have also tried the lost password feature 3 times. Any help that can be had? The email associated with the account is

Has your account been accepted? Easy way to check this is by using the Lost Password tool, and checking the associated email you provided upon registration.

If it says "Invalid Email", you will need to reregister, if you get a Email Sent (Or something along those lines). Check your email, and try that password.

If the other methods have failed, click here (Made a Clicky!) to be taken to the support page, and file a support ticket. Explain your situation, and I would imagine the Asims would add a Login Exception for you (Allowing you to login).

Please retry all the steps you followed, and mine first.


Edited By: Gavin Rollan on Year 13 Day 41 23:45

It has allowed to me to reset the password many times, but the new password has never worked. I did everything that was asked and then put in for that ticket in the support form.

Have you typed the password exactely as it appears? It's been years since ah changed mah password and can't remember if SWC passwords are caS3seNS1tvE or not

Passwords are case sensitive.


7:13 PM] Lartog Ulmug (Sanctuary): I've never been more scared seeing a naked penguin running at me full sprint
Also, what browser are you using? Make sure it's up to date (i.e. the newest version available).

I have used appropriate caps when needed. I have gone so far as to copy and paste the password but still no results. I am currently on the newest version of Explorer, but I have also used the newest version of Firefox as well as safari on my phone. I have even tried it on multiple computers, at multiple residences with no results.

What is the handle you selected? It may still be awaiting approval.

I have not been able to select a handle even. It wouldn't allow me to log in using the email account from the validation even though it HAS been validated. That is why this is so frustrating. All I have is a email and the ability to reset my password, but not to actually log in and do anything.

After a week, still no progress : /

Is no one going to address my issue?

Unfortunately at the moment I have to re-direct you to which is the site we the administration use to collect and address issues such as yours. I apologize that you have been in this holding-pattern without resolve for as long as you have, and it may still be a bit of time until we are able to solve your issue.

Until then, please create a new ticket at the above website and we'll try and get to your issue asap!

Edited By: Dollian Teague on Year 13 Day 54 15:02

Russ> This is an ok game with terrible people.